Lancia Motor Club Forum Banner
18 February, 2020, 10:43:13 AM *
Welcome, Guest. Please login or register.

Login with username, password and session length
 
   Home   Help Search Calendar Register  
Pages: [1]   Go Down
  Print  
Author Topic: S3 COUPE ELECTRICAL FAULT  (Read 1063 times)
0 Members and 1 Guest are viewing this topic.
Taggart
Lapsed
Member

Offline Offline

Posts: 3



« on: 29 May, 2008, 09:55:48 AM »

Can anybody give advice please on a problem that is driving me mad.
The 25A fuse that protects the ignition system blows on a regular basis for no apparant reason.

At first I thought it was a faulty ignition coil as it felt very hot the first time it happened, but after replacing twice it is still happening. I have checked over obvious wiring in around the distributor and through the bulkhead but can find no shorts or bad wiring.

Before i start to strip the steering column and igniton switch as anybody come across this before as a common problem with hopefully an easy answer? 

 
Logged
nistri
Megaposter
*
Offline Offline

Posts: 254


« Reply #1 on: 29 May, 2008, 04:13:56 PM »

After disconnecting the battery, remove the fuse and clean very carefully and systematically the fuse housing using small metal files. The surface should be returned to bright metal. Check that the electrical connections to the fuse housing are good and their bayonet fitting really clean. Refit the fuse and battery. Good luck,
Andrea
Logged

Andrea Nistri

Ardea S2
Appia S2
Fulvia GTE
Fulvia Sport 1.3 S
Fulvia Montecarlo
Fulvia Coupe 1.3 S
Pages: [1]   Go Up
  Print  
 
Jump to:  

Contact the Forum Administrator

LMC Forum copyright © 2007 - 2018 Lancia Motor Club Ltd

Powered by SMF 1.1.20 | SMF © 2006-2011, Simple Machines