Lancia Motor Club Forum Banner
13 December, 2019, 12:37:10 PM *
Welcome, Guest. Please login or register.

Login with username, password and session length
 
   Home   Help Search Calendar Register  
Pages: [1]   Go Down
  Print  
Author Topic: Fuses?  (Read 1432 times)
0 Members and 1 Guest are viewing this topic.
lee69
Guest
« on: 13 August, 2007, 04:28:10 PM »

MOT time is looming and the Ypsi's looking all curvy, blue and very shiny, but it's decided to throw a strop!

A few weeks ago the speedo lights went during a thunderstorm, then a sidelight, then a rear light, then a brake light...oh and the central locking played up for the first time in over a year.  Apart from that, my 600 eBay banger is going really well.

I replaced the side light bulb and the 10A fuse that looks after the offside sidelight, nearside rear light and speedo light.  All fine, then it did it all again, on the way home last night in the dark  Undecided.  I'm assuming it's the fuse again.  I'm expecting to find that the front sidelight bulb has gone and that's what's shorted the fuse.  Should a blown bulb, go on to blow a fuse?  Has anyone else had similar experiences? Huh?

By the way there are 2 Y10s on eBay at the moment a S2 Fire LX in white and a very pretty S1 Fire LX in metallic blue, rusty doors, body colour tailgate and its original wheeltrims!

Any Y10, Ys or Ypsilons going to Stanford Hall?

Lee
Logged
fay66
Permanent resident
**
Offline Offline

Posts: 5736



« Reply #1 on: 14 August, 2007, 01:17:27 AM »

Hi Lee,
Speak to Trevor Nicosia, He's run more Y's than anyone.
Never had a problem withe fuses on my Elefantino Rosso, although both the drivers side window lifter (Packed up) & the front discs (Vibration) were replaced under warranty, tried to get the bad paint chips on the bonnet done under warranty but Fiat wouldn't play ball as they reckon it was due to the paint being softer, which was down to them having to use environment friendly water based paint.
I also wasn't impressed with how rusty the passivated bracketry & servo started rusting, but they didn't want to know about that either Angry

If the rear wiper packs up anytime , DON'T try to use the Punto one, it's about half the price of the Y one, looks the same but actually fits up the other way Huh?

All in all it was a great motor & is still owned by the club member who bought it off me, & I think it will stay in his ownership unless I can persuade him to sell it back to me, Grin unlikely, but I have first refusal.

Brian Hilton
8227 Cool
Logged

Own 1966 Fulvia 2C Berlina since 1997, back on road 11-1999.Known as "Fay"
1999 Suzuki Wagon R+ GL, now my daughters
2006 Renault Megane 1 5 Dci Sports Tourer
Dedra Technical Adviser
lee69
Guest
« Reply #2 on: 14 August, 2007, 08:10:11 AM »

Brian

I knew you'd reply!  Window lifters  - yep the one that worked when I bought it died soon after and I had the brakes refurbed for the MOT last year.  They don't half rattle though - I think there's a shim of something missing (according to my Dad).

I tried the Punto wiper motor, it looked like it would work, but things just don't don't quite fit together do they?

I agree the paint is soft - it seems to chip very easily and very deeply.  It's going to be pampered from October as I won't need to use it to drive to work everyday.  Still, as with you, I still think the Y is a great little car and should have been imported into the UK.

Thanks for the advice,

Lee
Logged
Pages: [1]   Go Up
  Print  
 
Jump to:  

Contact the Forum Administrator

LMC Forum copyright © 2007 - 2018 Lancia Motor Club Ltd

Powered by SMF 1.1.20 | SMF © 2006-2011, Simple Machines