Lancia Motor Club Forum Banner
23 September, 2021, 02:51:48 AM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News: Need to contact the Forum Administrator? e-mail forum.admin@lanciamc.co.uk, for Database Administrator e-mail database.admin@lanciamc.co.uk      -      Copy deadline for Viva Lancia is 12th of each month.      -      For Events e-mail events@lanciamc.co.uk      -      To Join the club go to http://www.lanciamc.co.uk/join.htm
 
   Home   Help Search Calendar Register  
Pages: [1]   Go Down
  Print  
Author Topic: Speedo Kaputt  (Read 1362 times)
0 Members and 1 Guest are viewing this topic.
OckaPete
Guest
« on: 25 May, 2010, 08:20:45 PM »

Can anyone recommend a Speedo repair shop? I have tried JDO with no luck. S2 Sport.
Cheers Pete
Logged
HF_Dave
Megaposter
*
Posts: 485


Rust , What Rust !! I don't See any rust !!!


« Reply #1 on: 25 May, 2010, 09:04:47 PM »

Is the speedo the same as the coupe ? 1.6 or 1.3 ? Roll Eyes
Logged

My Current Cars:

1991 Thema station wagon
1989 Thema 16v
2011 Lancia Delta 3

1977 Beta sedan 2000
1975 Fulvia S3 1.3
1973 Flavia HF 2000 Coupe
1972 Fulvia S2 1.3
1989 Thema 8.32
**Other Makes**
2018 Alfa Giulia
1999 Alfa 156
2009 Fiat Du
lancialulu
Press Officer
Permanent resident
*****
Posts: 4329



« Reply #2 on: 25 May, 2010, 09:15:08 PM »

They are definately different between 1600 and 1300. The 1300 sport should be a veglia unit but is it part of the intrument assembly with tachometer etc or is it a seperate unit.

What has failed, maybe the cable is not working??

Tim
Logged

Its not the winning but taking part! or is it taking apart?
1955 Aurelia B12
1967 Flavia Vignale iniezione
1967 Fulvia 1.3HFR
1972 Fulvia 1600HF
1972 Fulvia 1600HF
1972 1600 Fulvia Sport
1979 2500 Gamma Coupe
1988 Delta 1.6GTi
1998 Zeta
Richard Fridd
Permanent resident
**
Posts: 3030



« Reply #3 on: 26 May, 2010, 06:13:55 AM »

try 'speedycables' at swansea.contact details are on their website
Logged

Richard Nevison Fridd                                                                      Happy Lancia, Happy Life
OckaPete
Guest
« Reply #4 on: 26 May, 2010, 10:22:34 PM »

Thanks, Ill try Speedy cables.  The cable seems to be quite new and moves freely. Also it is part of the whole cluster but comes out of the unit. It is a french made Jaeger and that seems to be the problem with repair shops, they will only do UK made Jaeger.
Cheers Pete
Logged
Pages: [1]   Go Up
  Print  
 
Jump to:  

Contact the Forum Administrator

LMC Forum copyright © 2007 - 2021 Lancia Motor Club Ltd

Powered by SMF 1.1.20 | SMF © 2006-2011, Simple Machines
Page created in 0.036 seconds with 20 queries.