Lancia Motor Club Forum Banner
23 September, 2021, 11:50:01 PM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News: Need to contact the Forum Administrator? e-mail forum.admin@lanciamc.co.uk, for Database Administrator e-mail database.admin@lanciamc.co.uk      -      Copy deadline for Viva Lancia is 12th of each month.      -      For Events e-mail events@lanciamc.co.uk      -      To Join the club go to http://www.lanciamc.co.uk/join.htm
 
   Home   Help Search Calendar Register  
Pages: 1 ... 4 5 6 7 8 [9]   Go Down
  Print  
Author Topic: Y10 GTie (LHD)  (Read 11995 times)
0 Members and 1 Guest are viewing this topic.
Duncan23
Member
****
Posts: 92



« Reply #120 on: 26 April, 2021, 10:49:14 AM »

One of the things that was holding me back from working on the car was that my welding helmet was refusing to stay dark (I only discovered this after waiting a few weeks and making a special trip to the welding supplier to buy gas!). The new one arrived last week (it is ace), so I could get on with things. It's nice being able to see what you are doing before you spark it up and during (and it's blue rather than green for some reason).

I actually made some progress on Saturday.  I glued in a metal reinforcing piece (one that I welded badly with my old helmet), which goes between the inside top of the dash and one of the bracing bars onto which the heater controls attach. I think that has really helped make the dashboard stiffer and hold the heater control unit in place. I also welded a small piece of rectangular tube to some sheet and drilled and tapped a hole, so hopefully I can glue that in place soon and provide something solid for the other side of the heater controls to attach to.  The pictures I took came out terribly though, so I can't show that. Sad I used the leftover epoxy to fill a bunch of the cracks, so hopefully that will also help.
I also undid the steering column bolts so I could get the dash back in again, and I did up a bunch of the connectors I undid when I thought that I was going to be able to get the dash out with part of the loom still attached. I even worked out where most of the connectors go (I was vary puzzled for a while until I remembered that lots had to go on the back of the instrument cluster which happened to be on the back seat)! This involved much banging of my head on the windscreen, so took yesterday off!
One thing I am aware of is that when it all has to go back together, I will need to put this thing back in (it goes in the engine bay between the heater gubbins and the engine). As you can see from the picture, it's utterly knackered. I doubt I can get a new one, and I'm guessing this is a problem for lots of Y10s and Pandas - what alternatives are there to just sticking this monstrosity back in the car?


* IMG_20210424_143229.jpg (2193.19 KB, 4608x3456 - viewed 44 times.)
Logged
frankxhv773t
Permanent resident
**
Posts: 2030



« Reply #121 on: 26 April, 2021, 06:56:20 PM »

All the ones I've had are fabric covered rather than that cracked hard finish so they survive much better. Again it begs the question as to whether they are "handed" but if not then you can probably find a UK spec one. Classic Panda is a completely different set up so no help.
Logged
Duncan23
Member
****
Posts: 92



« Reply #122 on: 27 April, 2021, 02:34:21 PM »

There's a sort of fabric on the engine side, and a hard plastic on the back.
It isn't symmetrical, but I think that's because of where the battery is - if the engine bay is the same for LHD and RHD ones then I would assume that this is the same too. I assume that's the sort of bulky annoying thing that no-one keeps spares of when they break a car. It can just go back in, but I figured if there was a good alternative I'd do that instead. Sounds like there isn't really...
Logged
Duncan23
Member
****
Posts: 92



« Reply #123 on: 04 May, 2021, 08:26:57 AM »

Made some more progress yesterday.
I tidied up and worked out where to place my welded beam, and I also drilled and tapped a couple of holes in it - one for the heater control and one for the attachment piece. I also tweaked the attachment piece so it's 95% good, and tapped a hole in that for the lower cover to go through (replacing yet another broken off plastic attachment point).
The photos show the bonded in metal support for the original plastic part and the newly bonded in steel tube plus attachment plate, what it looks like with the heater control in place, and the final piece of the puzzle that attached both sides and provides more rigidity and structure

I've trial fitted it with the cover and with the heater controls and the speedo unit individually - I need to trial fit everything together before I add the final part as I might need to chop the box about a bit (it's massive overkill for this, but it was easy).

Once I've got that done and the final piece bonded in, I can put the dash back in the car, connect everything up and take it for an MOT. I'm hoping there's not too much work needed so it can be ready for the Weekender.


* IMG_20210503_190618.jpg (810.05 KB, 4608x3456 - viewed 43 times.)

* IMG_20210503_190813.jpg (402.82 KB, 4608x3456 - viewed 40 times.)

* IMG_20210503_191011.jpg (548.2 KB, 4608x3456 - viewed 45 times.)
Logged
Duncan23
Member
****
Posts: 92



« Reply #124 on: 10 May, 2021, 03:11:15 PM »

Bloody car.
I installed that last bit of scaffolding Friday, gave it a day for the glue to set properly and then tried to fit it in the car Saturday. I got it basically in position, but then I realised that the wiring that goes to the back of the various dash pieces were out of place and I didn't know where they went. So I took the dash out again, found out where all the various connectors all went (at least Lancia made it so they were all different), zip tied them together so I knew which hole they should go through, and then tried to put the dash back in again. Unsuccessfully. And I broke at least one of my reinforcing structures (number 8 in the previous pictures - it tore the metal/epoxy away from the plastic). At that stage I shut the garage door and went for a walk, and I've not opened it since (if I had a hammer to hand after my time fighting the dashboard it would probably be in quite a lot of small pieces).

I'm beginning to think it's not possible to put the dash back in without attaching the wiring loom to the back of it (how it was before). Which means undoing a huge number of stuck together clips with the dash out, zip tieing the dash loom in place, putting the dash back in and praying I can re-attach all the dash clips when they are hidden behind the dashboard. All of which is enormously uncomfortable, and I keep banging my head on the windscreen. Grrr. I was trying to get this car sorted for an event on the 29th of May - not a chance. Sad Any tips or tools to make disconnecting and reconnecting all the cabling between the dash and the car easier?
Logged
frankxhv773t
Permanent resident
**
Posts: 2030



« Reply #125 on: 10 May, 2021, 06:45:46 PM »

My recollection is that the dash wiring is a separate loom from the firewall wiring so the dash can be lifted into place complete with its wiring and then the connectors are plugged into the loom on the firewall.


* Y10 dashboard rear right.JPG (89.84 KB, 640x480 - viewed 192 times.)

* Y10 dashboard rear left.JPG (91.21 KB, 640x480 - viewed 190 times.)
Logged
Duncan23
Member
****
Posts: 92



« Reply #126 on: 10 May, 2021, 07:15:12 PM »

That's right, but I couldn't unplug the loom when removing the dashboard!
Logged
Duncan23
Member
****
Posts: 92



« Reply #127 on: 17 May, 2021, 08:24:13 AM »

I bowed to the inevitable, put the dash back on the bonnet and started trying to undo the connectors between the dash loom and the car loom. I attacked most of it with contact cleaner before I started, but taking the connectors off the fusebox was painstaking.
2 hours later, I had disconnected most of the connectors by the steering wheel and removed this.

I guess I'll be spending some time trying to remove all that corrosion as well... The design is pretty neat in that none of the plugs can go back in the wrong place (at least I hope so - if they can I've got a lot of problems coming my way! Wink
There are some wires that seem to go through the firewall I need to trace, and I've got to deal with the relay box in the passenger footwell, and then the dashboard loom can come out. 2 steps backwards, one to go, hopefully it will be forwards from there.


* IMG_20210516_173032.jpg (1613.19 KB, 3456x4608 - viewed 42 times.)

* IMG_20210516_173040.jpg (1436.81 KB, 3456x4608 - viewed 42 times.)
Logged
Kevinlincs
Permanent resident
**
Posts: 1125


« Reply #128 on: 17 May, 2021, 08:31:45 PM »

If you have access to a blast cabinet I'd be inclined to do the back of the fusebox with that rather than contact cleaner, if not a friendly auto electric shop will do it for a drink I'm sure, had one looking like that on an Alfa once and it came up like new after a few minutes blasting.
It'll take ages by hand!
The terminals will most likely be as bad though...
Logged
Duncan23
Member
****
Posts: 92



« Reply #129 on: 27 August, 2021, 12:17:44 PM »

I finally started again trying to remove the dash bit of the loom. I disconnected some of the extra random wires, split them off and then reconnected them not tangled up. Everything was going fine, and all I needed to do was work out how to unhook it from the ignition switch.
I was hoping I could just unplug the whole connector and get much better access and see what's going on. The connector came out, and it had a red bit and a white bit, so I don't know why, but I split them apart, and er, as the pictures show, I shouldn't have done that:
I guess I'll have to work out how to put that back together again.  Roll Eyes
I labelled all the cables and detached them from the red part, but I still can't take the dashboard loom out as some of the cables coming from that are joined into the same connector as the car loom (where it connects into the ignition switch). I need to check the wiring diagrams to see if this is how it's supposed to be. If it is, I might have to put some extra connectors into those lines so I can split it all apart and pull the dashboard loom. Sigh.


* IMG_20210826_171554.jpg (274.48 KB, 4608x3456 - viewed 13 times.)

* IMG_20210826_171533.jpg (525.61 KB, 3456x4608 - viewed 12 times.)
Logged
Pages: 1 ... 4 5 6 7 8 [9]   Go Up
  Print  
 
Jump to:  

Contact the Forum Administrator

LMC Forum copyright © 2007 - 2021 Lancia Motor Club Ltd

Powered by SMF 1.1.20 | SMF © 2006-2011, Simple Machines
Page created in 0.089 seconds with 21 queries.