Lancia Motor Club Forum Banner
18 October, 2019, 08:08:35 PM *
Welcome, Guest. Please login or register.

Login with username, password and session length
 
   Home   Help Search Calendar Register  
Pages: 1 2 3 4 5 [6]   Go Down
  Print  
Author Topic: Flavia Coupe Servo Problem  (Read 12027 times)
0 Members and 1 Guest are viewing this topic.
Seara Cardoso
Member
***
Offline Offline

Posts: 33



« Reply #75 on: 21 April, 2015, 10:29:28 AM »

Long marathon last night with my father. We took apart the MC, the seals looked good and the interior of the pump, apart some minor scratches, was as new.

Reassembling and trying to bleed again we were having difficulties bleeding using the rear pump of the MC, it had some air stuck inside and was putting air into the system when pressed. We removed it and bled it successfully. Could the car have been badly bled before?

We also replaced all he coper washers from the MC and Servo just to be sure.

Now its time to do some miles in the car to check it its right again.

Ricardo


* IMG_3273.JPG (492.54 KB, 960x1280 - viewed 101 times.)

* IMG_3275.JPG (395.68 KB, 1280x960 - viewed 108 times.)

* IMG_3276.JPG (322.9 KB, 1280x960 - viewed 103 times.)

* IMG_3277.JPG (332.97 KB, 1280x960 - viewed 96 times.)
Logged

1956 Aurelia B20GT
1957 Appia Vignale
1963 Fulvia Berlina
1964 Flavia Berlina
1967 Flavia Coupe 1.8 Iniezione
1972 Fulvia 1600 HF
1972 Fulvia Berlina
1974 Beta Berlina 1800
1994 Thema LX
2008 New Delta
Pages: 1 2 3 4 5 [6]   Go Up
  Print  
 
Jump to:  

Contact the Forum Administrator

LMC Forum copyright © 2007 - 2018 Lancia Motor Club Ltd

Powered by SMF 1.1.20 | SMF © 2006-2011, Simple Machines