Lancia Motor Club Forum Banner
24 September, 2020, 07:41:43 AM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News: Need to contact the Forum Administrator? e-mail forum.admin@lanciamc.co.uk, for Database Administrator e-mail database.admin@lanciamc.co.uk      -      Copy deadline for Viva Lancia is 12th of each month.      -      For Events e-mail events@lanciamc.co.uk      -      To Join the club go to http://www.lanciamc.co.uk/join.htm
 
   Home   Help Search Calendar Register  
Pages: 1 [2]   Go Down
  Print  
Author Topic: Fulvia Fuse Ratings  (Read 4800 times)
0 Members and 1 Guest are viewing this topic.
DavidLaver
Permanent resident
**
Posts: 4144



« Reply #15 on: 07 June, 2014, 10:15:58 PM »


What added to my confusion is that this bulb went the day after I replaced another in the same cluster - so I was looking to blame something I'd done disturbing it - but it really had died...

David
Logged

David Laver, Lewisham.
stanley sweet
Lapsed
Permanent resident
**
Posts: 1149



WWW
« Reply #16 on: 08 June, 2014, 11:43:21 AM »

I think every one has wasted a few hours on this type of thing. The worst is when you fit a brand new part and still have the same problem.................then it turns out the new part is faulty too. Results in a wasted weekend you'll never get back!
Logged

1971 Fulvia 1.3S 'Leggera'  1999 Lancia Lybra 1.9JTD LX SW
Pages: 1 [2]   Go Up
  Print  
 
Jump to:  

Contact the Forum Administrator

LMC Forum copyright © 2007 - 2018 Lancia Motor Club Ltd

Powered by SMF 1.1.20 | SMF © 2006-2011, Simple Machines
Page created in 0.032 seconds with 22 queries.