Lancia Motor Club Forum Banner
27 January, 2020, 01:08:25 PM *
Welcome, Guest. Please login or register.

Login with username, password and session length
 
   Home   Help Search Calendar Register  
Pages: [1]   Go Down
  Print  
Author Topic: Poor starting when cold, Flavia 2000, Solex Carb  (Read 1362 times)
0 Members and 1 Guest are viewing this topic.
alan284flavia
Member
**
Offline Offline

Posts: 18


« on: 27 October, 2013, 09:22:03 PM »

For the last 2 years i have had extreme difficulty when starting my Flavia 2000 from cold, cranking for 2 or 3 minutes with short breaks. Spark is good, car runs well once fired up, hot starts ok but not brilliant but probably due to siting of fuel pump. Today it almost defied me, when I touched the connector to the anti run on unit on the carb., thereafter it fired up ok, did not seem flooded. Could this be the source of my problem ? There is also a FilterKing filter / regulator, couyld it be a problem, I am thinking of installing an electric pump, but would rather do it as a last resort. Any suggestions /
Logged
fay66
Permanent resident
**
Offline Offline

Posts: 5744



« Reply #1 on: 28 October, 2013, 12:28:02 AM »

For the last 2 years i have had extreme difficulty when starting my Flavia 2000 from cold, cranking for 2 or 3 minutes with short breaks. Spark is good, car runs well once fired up, hot starts ok but not brilliant but probably due to siting of fuel pump. Today it almost defied me, when I touched the connector to the anti run on unit on the carb., thereafter it fired up ok, did not seem flooded. Could this be the source of my problem ? There is also a FilterKing filter / regulator, couyld it be a problem, I am thinking of installing an electric pump, but would rather do it as a last resort. Any suggestions /

I've no experience of Flavia but certainly adding an electric pump but only to prime the carburettors, I then turn it off and resort to the mechanical fuel pump, it has been well worth it, no grinding over and usually starts first time.
I've also had a Filter King fitted for about 10 years now and it's never been a problem either.
Having read up a bit on Fulvias with the anti run on unit and the problems, that would be my first port of call, I maybe wrong, but I thought on Fulvia you can get away with disconnecting it in some way, I believe this was mentioned in a document on them from Omicron.
Good Luck sorting your problems.

Brian
8227 Cool
Logged

Own 1966 Fulvia 2C Berlina since 1997, back on road 11-1999.Known as "Fay"
1999 Suzuki Wagon R+ GL, now my daughters
2006 Renault Megane 1 5 Dci Sports Tourer
Dedra Technical Adviser
lancialulu
Press Officer
Permanent resident
*****
Offline Offline

Posts: 3652



« Reply #2 on: 28 October, 2013, 07:41:37 AM »

Thought all Flavias had electric pump fitted in boot area. You here it ticking when turning the ignition on and then it stops. If no ticking then perhaps the pump has a problem. I am only speaking from my experience of S1 cars and Vignale in particular.
Logged

Its not the winning but taking part! or is it taking apart?
1955 Aurelia B12
1967 Flavia Vignale iniezione
1967 Fulvia HFR
1972 1600 HF
1972 1600 Fulvia Sport
1978 Transformer HF3000 Strato's replica
1979 2500 Gamma Coupe
1988 Delta 1.6GTi.e.
Richard Fridd
Permanent resident
**
Offline Offline

Posts: 2872



« Reply #3 on: 28 October, 2013, 08:53:09 AM »

My transparent fuel filter bowl near to the carb is an indicator of whether fuel is being delivered. Also does it have a functioning cold start device? Earth strap ok?
Logged

Richard Nevison Fridd
rogerelias
Rebel Poster
*
Offline Offline

Posts: 939


MY 1600HF IN HEARTBEAT GARAGE


« Reply #4 on: 28 October, 2013, 06:35:44 PM »

Silly though it may seem, but have you checked to see if the choke flap is fully closed when the cable is pulled fully, i've see it before on MGB's
Logged

FULVIA 1600HF LUSSO
1958 VELOCETTE MAC
Triumph Bonneville t120v 1972
1968 MGC ROADSTER
1958 Series 2 Appia berlina
Richard Fridd
Permanent resident
**
Offline Offline

Posts: 2872



« Reply #5 on: 28 October, 2013, 08:19:45 PM »

Good point and hence my reference. My Flaminia was suffering poor starting due to the choke being on without my knowledge(mechanism over centre)
Logged

Richard Nevison Fridd
Pages: [1]   Go Up
  Print  
 
Jump to:  

Contact the Forum Administrator

LMC Forum copyright © 2007 - 2018 Lancia Motor Club Ltd

Powered by SMF 1.1.20 | SMF © 2006-2011, Simple Machines