Lancia Motor Club Forum Banner
27 May, 2019, 04:13:43 AM *
Welcome, Guest. Please login or register.

Login with username, password and session length
 
   Home   Help Search Calendar Register  
Pages: [1]   Go Down
  Print  
Author Topic: HF coupe 2000 running too rich  (Read 779 times)
0 Members and 1 Guest are viewing this topic.
HF_Dave
Megaposter
*
Offline Offline

Posts: 475


Rust , What Rust !! I don't See any rust !!!


« on: 13 April, 2011, 08:37:26 PM »

I am just back from our tour of Cork on the L M C I annual Rally. The car gave trouble including returning around 12miles to the gallon. Also a bad misfire. I think part of the problem is the fuel filter, after is stalled completely I tapped the filter and it ran again. I know nothing about the Bosch electronic fuel injection. Would the filter blockage be responsable for the poor fuel economy ? Thanks . David. 8228 Huh?
Logged

My Current Cars:
1997 Ypsilon 1.2 16v
2003 Ypsilon 16v
1989 Thema 16v

1977 Beta sedan 2000
1975 Fulvia S3 1.3
1973 Flavia HF 2000 Coupe
1972 Fulvia S2 1.3
1989 Thema 8.32
**Other Makes**
2008 Fiat 500
2006 Fiat Croma
2009 Fiat Ducato160ps,Mu
fay66
Permanent resident
**
Offline Offline

Posts: 5648



« Reply #1 on: 14 April, 2011, 01:30:26 AM »

I am just back from our tour of Cork on the L M C I annual Rally. The car gave trouble including returning around 12miles to the gallon. Also a bad misfire. I think part of the problem is the fuel filter, after is stalled completely I tapped the filter and it ran again. I know nothing about the Bosch electronic fuel injection. Would the filter blockage be responsable for the poor fuel economy ? Thanks . David. 8228 Huh?


Dave,
Very easily I would have thought, Dedra's with the canister filter sometimes had this problem as it was tucked up behind the O/s rear wheel and a bit inaccessible, and many garages and owners either didn't realise that it was there, or it was just too much hassle to get at to change, so they never did; as Dedra adviser I had quite a few of these turn up as a problem, but once the filter was changed, the problem had gone away.
So the worst scenario is that it costs you a little time and money, on the other hand it might easily solve your problem, but at least it will be one possible cause eliminated if not.

good Luck.

Brian
8227 Cool
Logged

Own 1966 Fulvia 2C Berlina since 1997, back on road 11-1999.Known as "Fay"
1999 Suzuki Wagon R+ GL, now my daughters
2006 Renault Megane 1 5 Dci Sports Tourer
Dedra Technical Adviser
HF_Dave
Megaposter
*
Offline Offline

Posts: 475


Rust , What Rust !! I don't See any rust !!!


« Reply #2 on: 19 April, 2011, 09:38:50 PM »

Thanks Brian, I bought two filters yesterday one plastic that goes between the tank and the pump and one metal that goes ahead of the pump. I'll fit them next Saturday and see how she runs. I dont know if this will cure the rich running though ?  Huh? . David.  Smiley
Logged

My Current Cars:
1997 Ypsilon 1.2 16v
2003 Ypsilon 16v
1989 Thema 16v

1977 Beta sedan 2000
1975 Fulvia S3 1.3
1973 Flavia HF 2000 Coupe
1972 Fulvia S2 1.3
1989 Thema 8.32
**Other Makes**
2008 Fiat 500
2006 Fiat Croma
2009 Fiat Ducato160ps,Mu
Pages: [1]   Go Up
  Print  
 
Jump to:  

Contact the Forum Administrator

LMC Forum copyright © 2007 - 2018 Lancia Motor Club Ltd

Powered by SMF 1.1.20 | SMF © 2006-2011, Simple Machines