Lancia Motor Club Forum Banner
03 March, 2021, 02:35:15 AM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News: Need to contact the Forum Administrator? e-mail forum.admin@lanciamc.co.uk, for Database Administrator e-mail database.admin@lanciamc.co.uk      -      Copy deadline for Viva Lancia is 12th of each month.      -      For Events e-mail events@lanciamc.co.uk      -      To Join the club go to http://www.lanciamc.co.uk/join.htm
 
   Home   Help Search Calendar Register  
Pages: [1]   Go Down
  Print  
Author Topic: Oil Temp Gauge  (Read 1777 times)
0 Members and 1 Guest are viewing this topic.
Nick Gramaglia
Lapsed
Member
****
Posts: 63



« on: 18 May, 2010, 08:44:02 PM »

I have been trying to fix the oil temp gauge in my HF and run out of ideas, I have checked the positive feed to the gauge thats ok, the wire that runs to the sender is not broken and connected both ends (gauge and sender) I have bought and fitted a new sender unit but still the gauge needle sits just left of the 60, do I maybe need a matched sender unit ? is the gauge likely to be at fault or is there something else I am missing ? any ideas would be much appreciated

Nick
Logged
lancialulu
Press Officer
Permanent resident
*****
Posts: 4128



« Reply #1 on: 18 May, 2010, 09:41:10 PM »

Tap the guage when the oil is hot. Mine sticks in my Z( I took it apart and desticked it but after a year it sticks again) but my HF works fine v odd....

Tim
Logged

Its not the winning but taking part! or is it taking apart?
1955 Aurelia B12
1967 Flavia Vignale iniezione
1967 Fulvia 1.3HFR
1972 Fulvia 1600HF
1972 Fulvia 1600HF
1972 1600 Fulvia Sport
1979 2500 Gamma Coupe
1988 Delta 1.6GTi
1998 Zeta
thecolonel
Guest
« Reply #2 on: 21 May, 2010, 11:03:53 AM »

Nick, first thing to try is :

take lead off sender, connect to earth point, gauge needle should go all the way
across, if it does then it's a faulty sensor or wire, if it doesn't it's a faulty gauge.

Geoff
Logged
neil-yaj396
Committee
Permanent resident
*****
Posts: 1054



« Reply #3 on: 21 May, 2010, 02:25:34 PM »

Geoff

Would this test work for an oil pressure guage as well? I've got a new sender unit which I haven't fitted yet. The guage showed a lower and lower  reading until it died last year on holiday.

Neil
Logged

1979 1300 Beta Coupe, 2014 Ypsilon 1.2 S Series Momo
thecolonel
Guest
« Reply #4 on: 21 May, 2010, 07:03:21 PM »

Hi Neil,
any gauge that uses a single wire sender will show same results

fuel, oil, water etc. disconnect sensor, earth out lead and gauge should show full reading.

Geoff
Logged
Nick Gramaglia
Lapsed
Member
****
Posts: 63



« Reply #5 on: 24 May, 2010, 01:31:52 PM »

Thanks for the advice

I have made some progress I have earthed the cable and the needle does indeed fly to the right, I have a brand new sender unit fitted and have got the car up to temperature and the gauge now is trying to work registering 64 when I tap the gauge it does jump up for a second so I presume it is now a case of a sticky needle, should it be reading half way at normal temperature ?

Nick
Logged
lancialulu
Press Officer
Permanent resident
*****
Posts: 4128



« Reply #6 on: 24 May, 2010, 04:32:32 PM »

Nick

My 1600 sport with sticky needle rarely registers above 75 which is low and I know the oil stat (it has a lancia oil cooler system) opens on a long hard run at c 85. My HF with same cooler gets up to 85-90 on a hard run (ie round goodwood!) so does not get to 100 ever in my ownership.

Tim
Logged

Its not the winning but taking part! or is it taking apart?
1955 Aurelia B12
1967 Flavia Vignale iniezione
1967 Fulvia 1.3HFR
1972 Fulvia 1600HF
1972 Fulvia 1600HF
1972 1600 Fulvia Sport
1979 2500 Gamma Coupe
1988 Delta 1.6GTi
1998 Zeta
Pages: [1]   Go Up
  Print  
 
Jump to:  

Contact the Forum Administrator

LMC Forum copyright © 2007 - 2021 Lancia Motor Club Ltd

Powered by SMF 1.1.20 | SMF © 2006-2011, Simple Machines
Page created in 0.057 seconds with 20 queries.