Lancia Motor Club Forum Banner
19 April, 2019, 03:31:04 PM *
Welcome, Guest. Please login or register.

Login with username, password and session length
 
   Home   Help Search Calendar Register  
Pages: [1]   Go Down
  Print  
Author Topic: Integrale electrical gremlins ?  (Read 1996 times)
0 Members and 1 Guest are viewing this topic.
GREENYORKIE
Member
****
Offline Offline

Posts: 76



« on: 01 April, 2010, 10:13:29 PM »

Taxed the Evo today after the winter lay up and went for a 10 mile warm up. At start up both the battery charging warning light and the indicator with the fuel injector symbol on it failed to extinguish. The multimeter reads 13.6v at idle so the alternator appears to be charging correctly.Anybody have any thoughts ? David.
Logged

Evo1 1992, Delta HPE HF 1998, Beta coupe 2000,1983.Audi TT. Delta HF Turbo,1988.
chugga boom
Non-LMC Seller
Permanent resident
**
Offline Offline

Posts: 1754



« Reply #1 on: 01 April, 2010, 10:42:56 PM »

i know its not a lancia but many moons ago i had an RS TURBO , this developed the same sort of fault and it was a break in the thin charging lamp wire onto the back of the alternator, gettin back to all things italian my my dedra did similar and it was a knackered alternator reg also my evo used to suffer with earth problems after it had been laid up through the winter even though it was garaged, worst one was the main engine earth corroded and burnt out the wiring from the dizzy to the ecu as the starter earthed through the ecu wiring under cranking, car started fine until it compleatly gave up and gave no warning of what was actually going on,this fault also used to bring on random warning lamps on the dash, worth just trying a jump lead from your battery earth straight onto the engine just incase, hope you sort it and let us know when you fix it
Logged

1935 augusta lusso (chugga)
1935 belna saloon
1935 augusta lusso
1938 ardenne
1939 aprilia lusso
1958 appia s2
1963 appia s3 
195? appia camioncino
1972 fulvia 1600HF
1976 fulvia coupe
194? ardea SUV  "THE BEAST!!!"
GREENYORKIE
Member
****
Offline Offline

Posts: 76



« Reply #2 on: 02 April, 2010, 08:10:11 PM »

Thanks for those thoughts James. I think we all know of the electrical foibles with Italian cars after years of ownership. I will have access to a friends' ramp at the weekend so will check out the earths and alternator lead.
Logged

Evo1 1992, Delta HPE HF 1998, Beta coupe 2000,1983.Audi TT. Delta HF Turbo,1988.
GREENYORKIE
Member
****
Offline Offline

Posts: 76



« Reply #3 on: 06 April, 2010, 08:37:24 PM »

With the help of an octopus managed to get the charging bulb lead off the alternator and found no fault with it. However metering the output from this lead showed 0v so looks like problem here is the alternator. As I know its charging correctly I may just disconnect the LED on the dash.
The " injection system malfunction warning light " as it is called in the handbook is now a temperamental so and so. Sometimes it goes out with the other warning lamps at start up and sometimes it doesn't. Anyone know where the signal for this lamp comes from.?
p.s. All accessable earths were clean and sound. David.
Logged

Evo1 1992, Delta HPE HF 1998, Beta coupe 2000,1983.Audi TT. Delta HF Turbo,1988.
thecolonel
Guest
« Reply #4 on: 06 April, 2010, 09:13:59 PM »

Be aware that a lot of alternators will not put out a charge without the warning light.

ie warning lamps do tend to come on and go off as the system reads a fault and then
the fault disappears

Geoff
Logged
chugga boom
Non-LMC Seller
Permanent resident
**
Offline Offline

Posts: 1754



« Reply #5 on: 06 April, 2010, 10:22:04 PM »

when my engine management light was coming on and off on its own ALLITALIA in wrexham simply adjusted the thottle pot and it went off, i dont know if thats the only thing to cause that problem but its all that was wrong with mine, geoff your correct in what you say, it may be worth trying a clip on ammeter to chech the output of the alternater while your at it, james
Logged

1935 augusta lusso (chugga)
1935 belna saloon
1935 augusta lusso
1938 ardenne
1939 aprilia lusso
1958 appia s2
1963 appia s3 
195? appia camioncino
1972 fulvia 1600HF
1976 fulvia coupe
194? ardea SUV  "THE BEAST!!!"
Pages: [1]   Go Up
  Print  
 
Jump to:  

Contact the Forum Administrator

LMC Forum copyright © 2007 - 2018 Lancia Motor Club Ltd

Powered by SMF 1.1.20 | SMF © 2006-2011, Simple Machines