Lancia Motor Club Forum Banner
06 March, 2021, 06:06:10 PM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News: Need to contact the Forum Administrator? e-mail forum.admin@lanciamc.co.uk, for Database Administrator e-mail database.admin@lanciamc.co.uk      -      Copy deadline for Viva Lancia is 12th of each month.      -      For Events e-mail events@lanciamc.co.uk      -      To Join the club go to http://www.lanciamc.co.uk/join.htm
 
   Home   Help Search Calendar Register  
Pages: [1]   Go Down
  Print  
Author Topic: AGM BREAKDOWN ??  (Read 1237 times)
0 Members and 1 Guest are viewing this topic.
rogerelias
Rebel Poster
*
Posts: 950


MY 1600HF IN HEARTBEAT GARAGE


« on: 14 July, 2009, 02:02:41 PM »

HAVE JUST BEEN TALKING TO A RECOVERY DRIVER FROM SHREWSBURY WHO DELIVERED A CAR TO US TODAY, AND I MENTIONED THAT I WAS THERE AT THE WEEKEND, HE SAID HE HAD TO TAKE A CAR AND 2 ELDERLY GENTLEMEN , BACK TO BIRMINGHAM WITH A Y REGD LANCIA CAR, THE CAR HAD A BROKEN REAR LOWER ARM JUDGING BY HIS DESCRIPTION, SOUNDS LIKE IT MAY HAVE BEEN A BETA, HOPE DAMAGE NOT TO SERIOUS, I THINK HE SAID THE PERSONS NAME WAS FIELD, SMALL WORLD.
Logged

FULVIA 1600HF LUSSO
1958 VELOCETTE MAC
Triumph Bonneville t120v 1972
1968 MGC ROADSTER
1958 Series 2 Appia berlina
fay66
Permanent resident
**
Posts: 5920



« Reply #1 on: 14 July, 2009, 02:24:19 PM »

It was Tony Field with his lovely Trevi, talking to Tony yesterday it seems that all of a sudden it started zig zagging across the road which was a bit frightening, on checking, one of the rear wheels had negative camber! a closer look indicated that a suspension link had bent Huh? while putting it on the AA wagon the AA bloke reckoned that the other side was bent as well.

Tony drove it to the AGM from Birmingham and was somewhere near Wenlock edge when the problem occurred.

Only thing that comes to mind is that he thinks that the links might have been damaged previously by someone jacking up on them when he had the bodywork sorted?
If Tony finds anything definitive I'll post it here.

I shan't tell Tony that the AA driver took his wife for an elderly Gentleman, although thinking on it he may have had someone else with them Roll Eyes

The Trevi needs new arms, but while he was waiting for the AA he had the radio on which means having the ignition turned on.
When he went to start the car, it wouldn't, so it's first port of call on the AA wagon on monday was an Auto Electrician, seems that by having the ignition on without the engine running he burnt out a connection, hence no start!

He now has the Trevi back home and waiting to fit new links.

Brian
8227 Cool
Logged

Own 1966 Fulvia 2C Berlina since 1997, back on road 11-1999.Known as "Fay"
1999 Suzuki Wagon R+ GL, now my daughters
2006 Renault Megane 1 5 Dci Sports Tourer
Dedra Technical Adviser
rogerelias
Rebel Poster
*
Posts: 950


MY 1600HF IN HEARTBEAT GARAGE


« Reply #2 on: 14 July, 2009, 03:38:51 PM »

SEE, i knew that someone would know about this Roll Eyes burnt a connection out by leaving ignition on, sounds like a Victor Meldrew moment about Italian electrics!! Wink
Logged

FULVIA 1600HF LUSSO
1958 VELOCETTE MAC
Triumph Bonneville t120v 1972
1968 MGC ROADSTER
1958 Series 2 Appia berlina
Thotos
Administrator
Megaposter
*****
Posts: 391


Theo Kyriacou


WWW
« Reply #3 on: 14 July, 2009, 05:07:17 PM »


 he had the radio on which means having the ignition turned on.


Having the ignition on without the engine running is always a bad idea. It was especially true of older cars with points because if the points were closed and the ignition left on, then current would constantly flow through the coil and would eventually burn the coil out. Can't think why the Trevi would have a problem with the ignition left on but even more strange is that my Trevi's radio works without having the ignition on. 
Logged

Theo Kyriacou
johnturner
Lapsed
Senior Member
*****
Posts: 111



« Reply #4 on: 14 July, 2009, 06:17:25 PM »

OK if its a really older car since leaving the ignition on in the Lambda just means that the magneto isn't earthed, but since i still haven't got round to fitting a radio that isn't much help.
Logged
Pages: [1]   Go Up
  Print  
 
Jump to:  

Contact the Forum Administrator

LMC Forum copyright © 2007 - 2021 Lancia Motor Club Ltd

Powered by SMF 1.1.20 | SMF © 2006-2011, Simple Machines
Page created in 0.053 seconds with 20 queries.