Lancia Motor Club Forum Banner
19 June, 2019, 12:12:41 AM *
Welcome, Guest. Please login or register.

Login with username, password and session length
 
   Home   Help Search Calendar Register  
Pages: [1]   Go Down
  Print  
Author Topic: back on terra firma  (Read 1922 times)
0 Members and 1 Guest are viewing this topic.
bill
Guest
« on: 11 June, 2009, 06:54:56 PM »

hi, back on four wheels, the car has spent more time up in the air than chitty chiitty bang bang.
more questions. fitted the new plug leads from omicron ( good delivery sevice) new oil  and filter.
I had the engine running but it would not pick up, idles ok. but if I put my foot to the floor the engine dies.
the car is fitted with an electric fuel pump with the ign. on I can hear the pump ticking which is normal, should it stop once the float chambers are full?
once again would appreciate any help.
cheers bill.


Logged
Richard Fridd
Permanent resident
**
Offline Offline

Posts: 2832



« Reply #1 on: 11 June, 2009, 07:10:23 PM »

an electric facet style pump will run continually assuming it has electrical power  connected but i do remember a duller 'ticking' sound once the chambers are full.the idle mixture must be ok.i also remember that my s2/3 would not pick up with air filter removed but ok at tickover and over 3000 rpm
Logged

Richard Nevison Fridd
lancialulu
Press Officer
Permanent resident
*****
Offline Offline

Posts: 3502



« Reply #2 on: 11 June, 2009, 08:28:29 PM »

sounds like a carb (both) problem. Throttle cable working the carbs??? Or main jets blocked? All my fulvias run happily without the air cleaner. If series 2/3 there is a fuel return pipe (norrow bore that stops carbs from over fueling this is another eason why an electric fuel pump contiunes to run albeit as Richard says at a slower duller sound when carbs have been filled.

Does car not rev at all? If there is a flat spot this could be timing, or accellerator pump problems.

Tim
Logged

Its not the winning but taking part! or is it taking apart?
1955 Aurelia B12
1967 Flavia Vignale iniezione
1967 Fulvia HFR
1972 1600 HF
1972 1600 Fulvia Sport
1978 Transformer HF3000 Strato's replica
1979 2500 Gamma Coupe
1988 Delta 1.6GTi.e.
fay66
Permanent resident
**
Offline Offline

Posts: 5657



« Reply #3 on: 12 June, 2009, 02:01:29 AM »

hi, back on four wheels, the car has spent more time up in the air than chitty chiitty bang bang.
more questions. fitted the new plug leads from omicron ( good delivery sevice) new oil  and filter.
I had the engine running but it would not pick up, idles ok. but if I put my foot to the floor the engine dies.
the car is fitted with an electric fuel pump with the ign. on I can hear the pump ticking which is normal, should it stop once the float chambers are full?
once again would appreciate any help.
cheers bill.



Hi Tim,
I have a solid state fuel pump fitted near the tank for priming which has a seperate illuminated switch, this flickers and you can hear the pump ticking until the carbs are filled, the pump then stops and the light remains steady, I then turn the switch off, pump the throttle half a dozen times, turn the key and the engine fires first time, at the same time as the engine fires I give it a bit of choke .
without using the choke at the same time, it is very easy to stall the engine within the first few seconds, after that no problem.

Brian
8227 Cool
Logged

Own 1966 Fulvia 2C Berlina since 1997, back on road 11-1999.Known as "Fay"
1999 Suzuki Wagon R+ GL, now my daughters
2006 Renault Megane 1 5 Dci Sports Tourer
Dedra Technical Adviser
dhla40
Senior Member
*****
Offline Offline

Posts: 119


« Reply #4 on: 12 June, 2009, 11:18:14 AM »

Hi Brian

I am interested in your electric pump set up, is it one of those small square facet jobs.  Could you tell me how you have plumbed it in and if it restricts the flow at all if still using the mech pump.

Sean
Logged

1976 1.3s coupe
1973 1.3s coupe
1982 montecarlo project
1976 alfa GT
1981 alfa spider
lancialulu
Press Officer
Permanent resident
*****
Offline Offline

Posts: 3502



« Reply #5 on: 12 June, 2009, 05:04:04 PM »

Andrea Nistri published the layout for series 2/3 fulvias in VL Nov 2004. This is for priming carbs after say more than a week usage so limits the starter motor grinding away to fill the carbs through the mechanical pump.

I fitted this set up to my 1971 1.3S coupe which uses T pieces to bypass the mechanical pump for intial priming. It uses a little Facet solid state pump. The pump could be used as a back up if the mechanical pump fails out on the road.

As series 2/3 have a fuel return from the carbs to the fuel tank, the pump will continue to work albeit more slowly. Brian's is a series one with no return so the pump stops (assuming the float chamber valves are in good order!). Generally the fuel return is to stop over pressurising the float valves (by the mech pump generally).

Interestingly I have a facet priming pump on a series 2 1600 sport but it is inline with the mech pump and seems to work well so no T pieces or extra plumbing.

I would also recommend an in line fuel filter as well.

Tim
Logged

Its not the winning but taking part! or is it taking apart?
1955 Aurelia B12
1967 Flavia Vignale iniezione
1967 Fulvia HFR
1972 1600 HF
1972 1600 Fulvia Sport
1978 Transformer HF3000 Strato's replica
1979 2500 Gamma Coupe
1988 Delta 1.6GTi.e.
fay66
Permanent resident
**
Offline Offline

Posts: 5657



« Reply #6 on: 12 June, 2009, 06:27:23 PM »

Hi Brian

I am interested in your electric pump set up, is it one of those small square facet jobs.  Could you tell me how you have plumbed it in and if it restricts the flow at all if still using the mech pump.

Sean
hi Sean,
I did reply but it seems to have gone walkabout! Mine was fitted by David Thomas garages at Codicote in Hertfordshire, who does the work I don't feel like doing on "Fay", they fitted a solid state pump that came from Demon Tweeks which cost about 42, I thought I had taken photos but I can't find them on my PC, I shall have "Fay" out of her lockup next week to give her a wash & brush up for the AGM, so I will see if I can take some photos for you and post here, I had intended pointing out Andrea's article in Viva Lancia but Tims beaten me to it, but as he remembered the date I'm glad he did.
Early series 1 Berlinas were not fitted with the fuel pressure regulator/filter so I obtained one from Demon Tweeks at about 36 and fitted it, coming back from Turin over the Alps I had no problems due to the altitude (did anyone?) and since fitting I've never had a problem with dirt in the fuel, so all in all well worth fitting if you don't have one already.

Brian
8227 Cool
Logged

Own 1966 Fulvia 2C Berlina since 1997, back on road 11-1999.Known as "Fay"
1999 Suzuki Wagon R+ GL, now my daughters
2006 Renault Megane 1 5 Dci Sports Tourer
Dedra Technical Adviser
Jai Sharma
Megaposter
*
Offline Offline

Posts: 352


« Reply #7 on: 12 June, 2009, 09:18:36 PM »

Was the car running o.k. before?

And how long was it since it was running? I have seen cars sitting for a long while which have managed to get blockages in the carbs.
Logged
bill
Guest
« Reply #8 on: 13 June, 2009, 06:25:01 AM »

hi, latest on the car, found the car does not like the choke, once i have pushed the choke lever home the engine idles well. if I press the acc. slowly the engine picks up well,if I push the acc. down quickish the engine dies and cuts out any ideas?

cheers bill.
Logged
bill
Guest
« Reply #9 on: 13 June, 2009, 06:37:26 AM »

the car has been standing for at least three years, I think it was running ok then, seems to be leading to a  blockage,

bill.
Logged
ncundy
Lapsed
Rebel Poster
*
Offline Offline

Posts: 980



« Reply #10 on: 13 June, 2009, 09:01:13 AM »

Sounds like the carbs need to come off and be cleaned and overhauled. Possibly the accelerator pump is full of dirt or the diaphram is split.
Logged

1969 Fanalone, Mazda RX-8, Fiat Multipla
Dilambdaman
Permanent resident
**
Offline Offline

Posts: 1311



« Reply #11 on: 13 June, 2009, 10:39:59 PM »

When I purchased my 2c some 10 years ago it was fitted with an SU fuel pump. The first owner carried out the conversion soon after buying the car in 1965. I reinstated the mechanical pump. He also fitted a hand throttle!

Original equipment on the Dilambda was a twin electric Auto-Pulse. Steady Barker assured me that they were lethal the spark from the points somehow igniting the petrol. Further more, the filter bowl had a tap on it which when opened sprayed petrol onto the air filter to aid starting from cold! As with the Fulvia my car had been fitted with an SU. It looked pretty unsightly on the bulkhead and although that was where the Auto-Pulse was mounted on the Series 1 mine, being an S2, they were relegated to the chassis forward of the tank. So, I fitted 2 of the Facet solid state pumps. Out of sight and totally reliable.

Robin.
Logged

Robin Lacey 3222

1932 Dilambda
1969 Fulvia S1 1.6HF Fanalone
davidwheeler
Permanent resident
**
Offline Offline

Posts: 1057



« Reply #12 on: 24 June, 2009, 06:48:04 PM »

Retarded timing???  My Lambda does that if I forget to advance the timing lever after starting.
David
Logged

David Wheeler.  Lambdas, Aprilia, Fulvia Sport.(formerly Appia and Thema as well).
Pages: [1]   Go Up
  Print  
 
Jump to:  

Contact the Forum Administrator

LMC Forum copyright © 2007 - 2018 Lancia Motor Club Ltd

Powered by SMF 1.1.20 | SMF © 2006-2011, Simple Machines