Lancia Motor Club Forum Banner
26 May, 2022, 11:25:52 PM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News: Need to contact the Forum Administrator? e-mail forum.admin@lanciamc.co.uk, for Database Administrator e-mail database.admin@lanciamc.co.uk      -      Copy deadline for Viva Lancia is 12th of each month.      -      For Events e-mail events@lanciamc.co.uk      -      To Join the club go to http://www.lanciamc.co.uk/join.htm
 
   Home   Help Search Calendar Register  
Pages: [1]   Go Down
  Print  
Author Topic: Magneti Marelli Horns  (Read 224 times)
0 Members and 1 Guest are viewing this topic.
DavidHill
Member
***
Posts: 27


« on: 10 February, 2022, 09:01:32 PM »

Hi,

I have got a pair of Magnetti Marelli snail horns (marked T68 A 12v) which i think are correct for my Aurelia, and would like to fit them in place of the more modern plastic horns currently fitted.  On applying power i can get one of the horns to work (it is the slave one with just one terminal) but i cannot get the other to operate/make any noise at all.  I have cleaned both sets of contact points and tried adjusting the main contact which goes to the central coil, but nothing (although i can see it sparking across the gap).  The outer contact at the bottom of the picture of the internals (which i think connect to the other slave horn) do move nicely on applying power.  Any ideas on how to fix these - or does it need to go to a specialist- in which case any ideas there on who would be able to fix it?

Many thanks
David.


* horn inside.jpg (317.64 KB, 960x1280 - viewed 19 times.)
Logged
Pages: [1]   Go Up
  Print  
 
Jump to:  

Contact the Forum Administrator

LMC Forum copyright © 2007 - 2021 Lancia Motor Club Ltd

Powered by SMF 1.1.20 | SMF © 2006-2011, Simple Machines
Page created in 0.034 seconds with 20 queries.