Lancia Motor Club Forum Banner
16 January, 2021, 07:06:45 PM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News: Need to contact the Forum Administrator? e-mail forum.admin@lanciamc.co.uk, for Database Administrator e-mail database.admin@lanciamc.co.uk      -      Copy deadline for Viva Lancia is 12th of each month.      -      For Events e-mail events@lanciamc.co.uk      -      To Join the club go to http://www.lanciamc.co.uk/join.htm
 
   Home   Help Search Calendar Register  
Pages: 1 ... 5 6 7 8 9 [10]   Go Down
  Print  
Author Topic: E55 LBR the parallel project  (Read 15272 times)
0 Members and 1 Guest are viewing this topic.
lancianut666
Permanent resident
**
Posts: 1249


Slow but rough


« Reply #135 on: 26 November, 2020, 08:44:31 PM »

Well float level was OK so all back together fired it up connected a tachometer and managed to get an idle of about 750-850 rpm but it was a bit uneven. So after a few laps we managed to get it into 3rd and even 4th a couple of times so it is running better and resisted the urge to stall but still lumpy low down. Thing is didn't really find anything... Old petrol?
Clarkey
Logged

Fulvia Coupe S2 Flavia Coupe 1967 1.8 Kugelfischer Prisma 1.6 carb Y10 Fila Y10 Touring Dedra 1.8 Dedra 2.0 Turbo Appia S1
Kevinlincs
Rebel Poster
*
Posts: 893


« Reply #136 on: 26 November, 2020, 11:11:43 PM »

Seems like you're getting there, some fine tuning and tinkering are the joys of carb cars, every box ticked gets you that bit closer,,
Logged
Dikappa
Megaposter
*
Posts: 449


« Reply #137 on: 27 November, 2020, 07:39:47 AM »

Have you re-checked the plugs after all this messing with the carb?  A new set is easily wasted and then replacing them can do wonders....Also if not running clean in hich rev ignition leads/cap/coils are suspect...
Has a compression test been done?
Logged
frankxhv773t
Permanent resident
**
Posts: 1875



« Reply #138 on: 27 November, 2020, 11:20:03 AM »

I have had running problems from the ignition module on the distributor. I never really established what was going on but running a wire from the mounting point to a good earth helped.
« Last Edit: 27 November, 2020, 11:45:40 AM by peteracs » Logged
Pages: 1 ... 5 6 7 8 9 [10]   Go Up
  Print  
 
Jump to:  

Contact the Forum Administrator

LMC Forum copyright © 2007 - 2021 Lancia Motor Club Ltd

Powered by SMF 1.1.20 | SMF © 2006-2011, Simple Machines
Page created in 0.062 seconds with 21 queries.