Lancia Motor Club Forum Banner
04 June, 2020, 03:55:53 AM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News: Need to contact the Forum Administrator? e-mail forum.admin@lanciamc.co.uk, for Database Administrator e-mail database.admin@lanciamc.co.uk      -      Copy deadline for Viva Lancia is 12th of each month.      -      For Events e-mail events@lanciamc.co.uk      -      To Join the club go to http://www.lanciamc.co.uk/join.htm
 
   Home   Help Search Calendar Register  
Pages: [1] 2   Go Down
  Print  
Author Topic: Fulvia 1600 HF Strange electrical issues  (Read 1155 times)
0 Members and 1 Guest are viewing this topic.
JJC
Member
*
Posts: 9


« on: 01 March, 2020, 05:40:42 PM »

Hi

Iím hoping someone may be able to advise on my cars strange behaviour.
Itís intermittent which makes it worse, so car starts and runs fine, however
for no reason I suddenly loose, all lights including brake lights, wipers, and heater fan
If I switch the car off, everything comes back to life, then when I start the engine again
Everything appears to work again for a while then the same issue, Iíve done all the obvious
checking fuse box etc. There is no issue with the ignition loosing power and cutting the engine.
Any advice appreciated Iím running out of ideas !

Regards

John
Logged
rogerelias
Rebel Poster
*
Posts: 945


MY 1600HF IN HEARTBEAT GARAGE


« Reply #1 on: 01 March, 2020, 08:14:31 PM »

Hi.as a guess there seems possibly to be a high resistance problem somewhere. Check chassis earth, and connections onto starter motor,not sure if there is a fuse by the starter motor.. everything should go through the ignition switch I think. Just a few pointers, I am sure someone on here will come up with other solutions. good luck
Logged

FULVIA 1600HF LUSSO
1958 VELOCETTE MAC
Triumph Bonneville t120v 1972
1968 MGC ROADSTER
1958 Series 2 Appia berlina
lancialulu
Press Officer
Permanent resident
*****
Posts: 3835



« Reply #2 on: 02 March, 2020, 07:22:17 AM »

Is the light switch stalk assembly loose, or broken wire inside it. Seem to recall this happened on my car and that was the culprit. Also maybe the ignition switch?. Look at a wiring diagram.
Logged

Its not the winning but taking part! or is it taking apart?
1955 Aurelia B12
1967 Flavia Vignale iniezione
1967 Fulvia 1.3HFR
1972 Fulvia 1600HF
1972 Fulvia 1600HF
1972 1600 Fulvia Sport
1979 2500 Gamma Coupe
1988 Delta 1.6GTi
1998 Zeta
Jai Sharma
Megaposter
*
Posts: 374


« Reply #3 on: 02 March, 2020, 07:50:03 AM »

the light and/or ignition switch occurred to me too.
Logged
nistri
Megaposter
*
Posts: 299


« Reply #4 on: 02 March, 2020, 08:16:00 AM »

Open the fuse box after disconnecting the (-) terminal on the battery. Go to the first fuse on the left, remove it and replace it after careful cleaning of the contacts with a small file to obtain bright metal. Check that the Lucar connectors at the same fuse are OK and that nothing is loose. Andrea
Logged

Andrea Nistri

Ardea S2
Appia S2
Fulvia GTE
Fulvia Sport 1.3 S
Fulvia Montecarlo
Fulvia Coupe 1.3 S
JJC
Member
*
Posts: 9


« Reply #5 on: 02 March, 2020, 11:37:43 AM »

Thanks for advice so far Smiley I will strip and clean light and wiper stalk and maybe the ignition switch
And re check the fuse box. I think the earths are OK.
Logged
JJC
Member
*
Posts: 9


« Reply #6 on: 02 March, 2020, 08:00:29 PM »

So cleaned all the contacts on the lights and wiper stalks
wiring all looks ok, removed and striped the ignition
barrel and there was one dirty contact which was blue/ black
wire which I believe goes back to fuse box. Iíve cleaned it
up and put it back together so will try and get it back in the car tomorrow 🤞
Logged
Jai Sharma
Megaposter
*
Posts: 374


« Reply #7 on: 02 March, 2020, 10:46:05 PM »

If that doesn't work it is well worth following the advice Andrea has posted.
Logged
lancialulu
Press Officer
Permanent resident
*****
Posts: 3835



« Reply #8 on: 03 March, 2020, 06:54:33 AM »

The lighting switch assembly must be tight on the outer housing and this must be tight also on the steer column as this is where it derives earth. I have seen fibre washers which creates problems...
Logged

Its not the winning but taking part! or is it taking apart?
1955 Aurelia B12
1967 Flavia Vignale iniezione
1967 Fulvia 1.3HFR
1972 Fulvia 1600HF
1972 Fulvia 1600HF
1972 1600 Fulvia Sport
1979 2500 Gamma Coupe
1988 Delta 1.6GTi
1998 Zeta
JJC
Member
*
Posts: 9


« Reply #9 on: 05 March, 2020, 04:43:11 PM »

Not had a change to take the car out yet but everything is back together, and appears to be functioning, Is it normal for the wipers and heater fan to work without key in ignition ? I can also switch lights on with ignition. Horn and indicators require ignition.

Regards

John
Logged
JJC
Member
*
Posts: 9


« Reply #10 on: 05 March, 2020, 04:45:57 PM »

Sorry I meant lights can be switched on without key in ignition
Logged
nistri
Megaposter
*
Posts: 299


« Reply #11 on: 06 March, 2020, 01:42:57 PM »

Yes, correct
Logged

Andrea Nistri

Ardea S2
Appia S2
Fulvia GTE
Fulvia Sport 1.3 S
Fulvia Montecarlo
Fulvia Coupe 1.3 S
JJC
Member
*
Posts: 9


« Reply #12 on: 06 March, 2020, 03:00:42 PM »

Thanks Andrea 🤞 itís sorted
Logged
lancialulu
Press Officer
Permanent resident
*****
Posts: 3835



« Reply #13 on: 06 March, 2020, 04:35:21 PM »

so what was it. Fuse or ignition switch? or lights switch earthing?
Logged

Its not the winning but taking part! or is it taking apart?
1955 Aurelia B12
1967 Flavia Vignale iniezione
1967 Fulvia 1.3HFR
1972 Fulvia 1600HF
1972 Fulvia 1600HF
1972 1600 Fulvia Sport
1979 2500 Gamma Coupe
1988 Delta 1.6GTi
1998 Zeta
JJC
Member
*
Posts: 9


« Reply #14 on: 07 March, 2020, 08:03:19 AM »

Hi

It could be a combination but I think it was ignition, I could post some pics
If I knew how to ! I hope to test it properly this weekend.
Logged
Pages: [1] 2   Go Up
  Print  
 
Jump to:  

Contact the Forum Administrator

LMC Forum copyright © 2007 - 2018 Lancia Motor Club Ltd

Powered by SMF 1.1.20 | SMF © 2006-2011, Simple Machines
Page created in 0.066 seconds with 21 queries.