Lancia Motor Club

Model Technical and Interest => Fulvia => Topic started by: andyps on 20 February, 2021, 01:25:47 PM



Title: Heater fan
Post by: andyps on 20 February, 2021, 01:25:47 PM
A simple question, is the heater fan single speed? Mine wasn't working and whilst I've got the dashboard dismantled to replace the cables I've been looking at the switch - I can see why the switch doesn't work it but I think I can sort that. I can get the fan to operate by connecting across the terminals but only at one speed, I'm not sure from looking at the underside if there should be two speed setting so wondered if anyone can let me know if that is correct.


Title: Re: Heater fan
Post by: RDG496 on 20 February, 2021, 05:49:40 PM
Up until recently my fan (S2 car) did not work, then when I was fiddling the lever it fired up. It has 2 speeds for sure but when I dismantled the centre dash the contacts the lever sweeps across look worn hence its very sensitive to any lever adjustment.


Title: Re: Heater fan
Post by: andyps on 20 February, 2021, 08:08:29 PM
Thanks, from the look of the switch it looked like it should have two speeds but I only got it to work on one speed which I'm thinking is the most powerful. I'll have to do more contact cleaning!


Title: Re: Heater fan
Post by: Neil on 20 February, 2021, 08:28:08 PM
Series 2 cars have a two speed heater fan


Title: Re: Heater fan
Post by: nthomas1 on 21 February, 2021, 09:40:41 AM
They say a picture is worth a thousand words, so here's a picture of the fan control lever from my S2 taken when I had removed the heater control assembly for refurbishment.  You can see that the lever is in the off position and you can see the first and second speed contacts.  The metal is quite thin on the contacts and it would not take much corrosion to stop one from working.


Title: Re: Heater fan
Post by: andyps on 21 February, 2021, 12:18:01 PM
Thanks Norm. That is what mine looks like and why I thought it should be two speed. It's only working when I connect across to the left had one in that picture, the centre one isn't doing anything so must need more cleaning. The part of the switch that moves to connect them is along way from the connections on the swit h body though so I think I'll take it off to reshape it.


Title: Re: Heater fan
Post by: andyps on 21 February, 2021, 09:57:31 PM
Sorted the switch mechanism so it works correctly on the slider but can't make a connection on the red wire that goes to the middle terminal, connecting it directly to the power feed doesn't make what I presume should be the slower fan speed work so there must be a connection issue elsewhere frustratingly. I'm a lot less worried about that though than the cable for the heater valve being completely inaccessible at the valve to release the outer cable fastening!


Title: Re: Heater fan
Post by: andyps on 21 February, 2021, 10:04:46 PM
To try an answer the cable question I was just looking at Norm's thread on the rebuilt and saw the picture at the very bottom of page 34 (copied to this post) - https://www.lancia.myzen.co.uk/forum/index.php?topic=9873.495 - and the black/blue and yellow wires are the opposite way round to the way they are on mine which may account for the issue, can anyone confirm if that picture is correct?
(https://www.lancia.myzen.co.uk/forum/index.php?action=dlattach;topic=9873.0;attach=48840;image)


Title: Re: Heater fan
Post by: andyps on 21 February, 2021, 10:28:15 PM
I had packed up for the night but decided to go back out and try - I have a two speed fan, the wires in the picture are correct it seems and mine had been fitted the wrong way round. Possibly because it is very tight getting the black/blue to the correct terminal, the wire feels a little short when the switch mechanism is pulled out of the dash. Anyway, pleased about that!!